Один журнал Beancount может охватывать несколько файлов. Разделение журнала — например, по одному файлу на год, на семейство счетов или на класс активов — помогает упорядочить большие журналы и упрощает архивирование старых транзакций. Beancount связывает файлы вместе с помощью директив include в main.bean.
Выполните следующие шаги, чтобы создавать дополнительные файлы и управлять ими в редакторе beancount.io:
Создание нового файла
Перейдите на вкладку редактора файлов на левой панели навигации. Откройте выпадающее меню "File" и нажмите "Create a new file".

Присвоение имени новому файлу
Задайте файлу допустимое имя и сохраните его. Каждое имя файла должно заканчиваться на .bean.

Подключение файла
Этот шаг обязателен: подключите только что созданный файл в main.bean, иначе его записи не будут частью журнала.
Например, если вы добавили stock.bean, добавьте include "stock.bean" в main.bean.

Подключите управляемый поток котировок
Hosted Beancount.io также может разрешать поддерживаемый URL котировок как виртуальный файл, доступный только для чтения. Используйте средство выбора Live Prices и руководство по настройке, чтобы выбрать потоки и вставить их директивы include в файл, загружаемый вашим журналом. Управляемые котировки — это не редактируемые файлы, создаваемые в рамках этого рабочего процесса. В оригинальном Beancount и Fava требуются локальные файлы котировок; совместимые версии bea имеют отдельную поддержку управляемых include.
Обновление и переход к файлу
Обновите страницу, и файл появится в выпадающем меню "File".

Переименование или удаление файла
Откройте файл и переименуйте или удалите его через выпадающее меню "Edit".

Возникли проблемы?
Задавайте вопросы в группе Beancount в Telegram.